tnir Linux Problems

by ,

Well, tnir crashed in the middle of doing a apt-get dist-upgrade.
This is pretty much the same as “Software Update” on a Mac.
I’m going to spew reams of info, so only click to read more if you’re really interested..


Well, I am using atrpms, which gives you an apt-get interface for rpms.
My first attempt died partway through, with the last few lines of output being:

kdesdk                      ##################################################
libxml2-python              ##################################################
rpm-python                  ##################################################
kdegames                    ##################################################
kdemultimedia               ##################################################
koffice                     ##################################################

So before I went ot bed I started another apt-get dist-upgrade, and found this in the log file (truncated for brevity):

Fri Sep 16 02:07:23 EDT 2005
Reading Package Lists...
Building Dependency Tree...
You might want to run `apt-get --fix-broken install' to correct these.
The following packages have unmet dependencies:
  ImageMagick-c++-devel#6.2.2.0-2.fc3: Depends: ImageMagick-c++ (= 6.2.2.0) but 6.0.7.1-5.fc3 is installed
                                       Depends: ImageMagick-devel (= 6.2.2.0) but 6.0.7.1-5.fc3 is installed
  glibc-common#2.3.4-2.fc3: Conflicts: glibc (> 2.3.4)
  glibc-common#2.3.5-0.fc3.1: Conflicts: glibc (< 2.3.5)
  kdeartwork-icons#3.4.2-0.fc3.1: Depends: kdeartwork (= 3.4.2) but 3.3.1-1 is installed
[... 20 similar lines, mostly dealing with php]
  php-snmp#4.3.11-2.7: Depends: php (= 4.3.11-2.7) but 4.3.10-3.2 is installed
                       Conflicts: net-snmp-libs (< 5.2.1)
  php-xmlrpc#4.3.11-2.7: Depends: php (= 4.3.11-2.7) but 4.3.10-3.2 is installed
W: There are multiple versions of "php-domxml" in your system.

This package won't be cleanly updated, unless you leave
only one version. To leave multiple versions installed,
you may remove that warning by setting the following
option in your configuration file:

RPM::Allow-Duplicated { "^php-domxml$"; };
To disable these warnings completely set:
RPM::Allow-Duplicated-Warning "false";
[359 repeated messages like the above between "W:" and "RPM::Allow-Duplicated-Warning"]

After seeing that I figured there were a lot of new packages installed without removing the old ones.
Checking the man page, it seemed that apt-get --fix-broken install
was the answer.
However, running that gave me this trepidatious output:

Reading Package Lists...
Building Dependency Tree...
Correcting dependencies... Done
The following extra packages will be installed:
  ImageMagick#6.0.7.1-4 cups-libs#1:1.1.22-0.rc1.8 gd#2.0.28-1
  iiimf-libs#1:12.1-4 libavc1394#0.4.1-3 libraw1394#0.10.1-3 openjade#1.3.2-14
  perl-HTML-Parser#3.35-6 perl-XML-Parser#2.34-5 policycoreutils#1.17.6-2
  popt#1.9.1-21 ruby-libs#1.8.1-7 xorg-x11-font-utils#6.8.2-1.FC3.13 yum20
The following packages will be upgraded
  yum20
The following packages will be REMOVED:
  DCC#1.2.71-11.rhfc3.at DCC#1.3.0-12.rhfc3.at FreeWnn Guppi-devel
  ImageMagick#6.0.7.1-5.fc3 ImageMagick#6.2.2.0-2.fc3 ImageMagick-c++
  ImageMagick-c++-devel#6.0.7.1-5.fc3 ImageMagick-c++-devel#6.2.2.0-2.fc3
  ImageMagick-devel ImageMagick-perl MagicPoint MyODBC#2.50.39-19.1
  MyODBC#2.50.39-25.FC3.1 MySQL-python Omni-foomatic VFlib2-conf-ja aalib
  abiword ac-archive acl acpid adjtimex alsa-utils#1.0.9rf-14.rhfc3.at am-utils
[.. 300 similar lines ..]
  xorg-x11-xdm#6.8.2-1.FC3.13_2.rhfc3.at
  xorg-x11-xfs#6.8.1-12.FC3.21_1.rhfc3.at
  xorg-x11-xfs#6.8.2-1.FC3.13_2.rhfc3.at xpdf xsane xsane-gimp xsnow yelp
  yp-tools ypbind ypserv ytalk yum#2.2.0-54.rhfc3.at yum#2.3.4-62.rhfc3.at
The following NEW packages will be installed:
  ImageMagick#6.0.7.1-4 cups-libs#1:1.1.22-0.rc1.8 gd#2.0.28-1
  iiimf-libs#1:12.1-4 libavc1394#0.4.1-3 libraw1394#0.10.1-3 openjade#1.3.2-14
  perl-HTML-Parser#3.35-6 perl-XML-Parser#2.34-5 policycoreutils#1.17.6-2
  popt#1.9.1-21 ruby-libs#1.8.1-7 xorg-x11-font-utils#6.8.2-1.FC3.13
WARNING: The following essential packages will be removed
This should NOT be done unless you know exactly what you are doing!
  glibc#2.3.4-2.fc3 (due to apt#1:0.5.15cnc7-57.rhfc3.at)
  libselinux#1.19.3-1_1.rhfc3.at (due to apt#1:0.5.15cnc7-57.rhfc3.at)
  mkinitrd#4.1.18.1-1 (due to initscripts#7.93.7-1) initscripts#7.93.5-1 (due
  to initscripts#7.93.7-1) kernel#2.6.10-1.741_FC3 (due to
  initscripts#7.93.7-1) librpm4.3#4.3.3-8_40.rhfc3.at (due to
  rpm#4.3.3-8_40.rhfc3.at)
1 upgraded, 13 newly installed, 1000 removed and 29 not upgraded.
Need to get 7220kB/7356kB of archives.
After unpacking 5322MB disk space will be freed.
You are about to do something potentially harmful
To continue type in the phrase 'Yes, do as I say!'
 ?] n
Abort.

Obviously I aborted the attempt, since it looked like it was going to gut my system!
Removing 1000 packages does NOT seem like a good idea!
If anyone has any bright ideas, please let me know.
Meanwhile, I will browse
the atrpms users mailing list archives
because this kind of thing must be a relatively common occurence.
All you need is a power failuer in the middle of a dist-upgrade!

Reid, software, web site.

About rae

I'm a long-time Mac and iOS developer. I'm also a big fan of Ruby on Rails and relational databases. I tend to work remotely, in my basement with occasional trips to the office. I'm also a big videophile, both TV and film, and can't wait for a good, inexpensive home 4k solution.

3 comments on “tnir Linux Problems

  1. Jeff K

    Well, upgrading the c-libs leads to that directly. At this point, I usually get a new distribution and do things as a complete system upgrade, but I have less to lose doing that than most folks.

  2. rae Post author

    Well, before I rush off and upgrade to Fedora Core 4 I’d like to learn how to deal with this kind of situation. It’s come up before.

    If it helps anyone figure this out, here is a list of all currently installed packages, as of a few minutes ago.

  3. rae Post author

    As further information, I’ve been checking the package ‘artscat’ just as an example. Here is the output of rpm -q -f /usr/bin/artscat:
      arts-1.3.1-1
      arts-1.4.2-0.fc3.3
    And yet, artscat -v, which reports its version says:
      artscat 1.4.2
    So clearly, the newer rpm has been installed in this case. So now do I need to go through each rpm and check manually? I’ve been looking around and the closest thing I can find to a “rebuild rpm database” command is “rpm --rebuilddb“, which I ran and which generated no output and also made no difference to the above commands.
    🙁

Leave a Reply

Your email address will not be published. Required fields are marked *